Ancestral Author Plus Tutorial
This tutorial will help you get started with Ancestral Author Plus (AA), a desktop software application
that creates genealogical documents from GEDCOM files. No prerequisite knowledge is required,
except for a basic understanding of what a GEDCOM file is, and what a genealogical descendant report
is. For more information, visit the Ancestral Softworks website (www.AncestralSoftworks.com).
First, let's get familiar with the Ancestral Author screen:

On the right you'll notice a bunch of labeled buttons. These are items that can be placed into your
genealogy document:
•

Title Page - usually goes first in your document,

•

Table of Contents - usually goes towards the front of your document,

•

Index - index of names, usually goes toward the end of your document,

•

etc

To place them in your document, use your left mouse button to select a document item, then drag it to
the screen on the left, and release the left mouse button. This will insert the item into your document.
This is how you build the document, adding one document item at a time, until you have the full
document layout. We'll go through this in more detail later. But before we do that, let's look more
closely at the AA screen.

Registering Ancestral Author Plus
Press the Register button to enter the user name and serial number that comes when you purchase
Ancestral Author Plus. You don't need to do this to use AA, but it prevents a watermark from appearing
across the pages of the genealogy document. You can still read the document when the watermark is
present, but it looks a lot better without it.

Script Files
Script files save the layout of the document in a file on your computer. Next time you want to work on
that document, open the script file, and you can continue where you left off.
To save a script file, select the Script menu item, then select Save As:

Put the script file somewhere that you can remember, preferably in your Documents folder. Once you
have saved your script file, you'll notice that the name of the file is shown at the bottom of the screen.
AA automatically gives your output document the same name as the script file (with a different

extension). This name is displayed on the top of the screen. The picture below shows these names
underlined in red:

Output Document
The Document menu item allows you to change the name of your genealogy document, and to view it
(assuming you've already created it):

Notice that the Document menu item has a Help selection. All menu items have help, as do all of the
screens in AA.

Help

The Help menu item includes a quick start tutorial, somewhat less detailed than this one. It also has a
menu item (Contents) that brings up the full AA help document, including a basic Getting Started
overview of Ancestral Author Plus. The Quick Start Tutorial and the Getting Started section are both
highly recommended for new users. They give a basic overview of Ancestral Author Plus.
The AA help document is organized in a hierarchy. When you select the Help->Contents menu item,
you'll see the help document shown below:

To see the hierarchical layout of the help document, click the tiny + next to the Ancestral Author book
icon on the left, circled in red above. This will show the various chapters and sections in the help
document. The picture below shows two of the tiny + icons expanded. The GEDCOM Drag And Drop
topic is selected for display:

Format And Phrases Menu Items
These menus are used to control the appearance of your genealogy document. More details about them
are reserved for another tutorial. If you are interested, you can always select the Format->Help or
Phrases->Help menu items.

Creating a Descendant Report With a Name Index
The remainder of this tutorial will step through the process of creating a descendant report, showing the
progeny of a particular individual. The document will include a title page, a table of contents, the
descendant report with source citations, and a name index.
The process of creating this document includes:
•

dragging the document items from the right panel to the left panel,

•

selecting the desired options that control the appearance of the document, and

•

pressing the Create ODT or Create PDF button to create the document.

We'll add the document items one at a time in the following sections. You don't need to add the items in
order. If you wanted, you could add the last item first (maybe the Index). Whenever you add an item,
you get to choose where it will go in the document.

Title Page
The title page is the front cover of your document. You don't need to put a title page on your document,
but it makes for a better appearance. Ancestral Author Plus allows you to put three things on the title
page:
1. the title of your document,
2. an image, perhaps a coat of arms, or some graphic that represents the contents of your
document, and
3. a byline, identifying the author, perhaps the date the document was created, or any other
identifying text.
Only the title is required. The picture and byline are optional.
Note that if you want different items on your title page (maybe you want two pictures instead of one),
you can always edit these into the document after you've created it - assuming you are generating open
document text (ODT), vs. portable document format (PDF). The ODT document can be edited in any
way you want with LibreOffice (or OpenOffice).
Once you drag the Title Page button into the Document Layout panel on the left, AA will show the
Title Page dialog (shown below). All three options have been supplied in the example dialog below.
Regarding the image - AA provides a small set of images that you can use if you don't have one of your
own. Simply click on the browse button (with the three small dots) to the right of the image field, then
choose the image that you want. If you have your own, then select it instead (you will have to navigate
through the file system to find it).

Note the forward slashes '/' in the text. These mark new lines. So the title will look like this:

Descendants of Seth Wheelock
of
Charlton, Massachusetts

Also, note the Help button. This will bring up detailed help about the title page.

Table of Contents
Drag the Table of Contents button onto the document layout panel on the left, and position it after the
Title Page. You will see the table of contents dialog, shown below.

By default, headings in the table of contents are hyperlinked to the associated section in the document.
This can be disabled by unchecking the Create Hyperlinks checkbox.
Note the reminder in blue at the bottom, above the buttons. ODT documents do not have their table of
contents or their name indexes filled in until you select the following menu item in LibreOffice or
OpenOffice:
Tools->Update->Update All
This will expand the TOC and the name index. For large documents, this may take a while, up to a half
minute. During this 'expansion/update' process, LibreOffice is scanning the entire document, looking
for headings that should go into the table of contents, and looking for names that should be indexed. If
you decide to add additional sections to your document in LibreOffice (or OpenOffice), say another
chapter at the beginning that gives credit to those who helped with your genealogical research - then
you will have to run the update again. This is because the page numbers in the name index will have
changed, and the table of contents will now have a new section.

Descendant Report
In most circumstances, a descendant report will be preceded by a heading, something like:
"Descendants of Seth Wheelock (about 1752 - 1806)". So the first step is to add a heading to the

document, positioned after the table of contents. Drag the Heading button onto the layout panel on the
left. When you release the mouse button, you'll see this dialog:

You can choose between three levels of headings. Level 1 headings force a page break, so that the
heading will always appear at the top of a new page. We are using a level 1 heading here, because we
want the descendant report to start on a brand new page. Otherwise, it would appear on the same page
as the table of contents.
Next, we drag the Descendant Report button onto the document layout panel, positioned after the
heading we just added. This will bring up the descendant report dialog:

There is one essential piece of information that must be supplied for a descendant report, namely the
GEDCOM file that contains the genealogical information. The rest is optional.
We strongly recommend using the browse button (three small dots) to select your GEDCOM file. This
is far preferable to typing it in, much less prone to error.
The Root individual is the first person in the descendant report. Everyone else in the report is a
descendant of that person. By default, AA will choose the person with the most progeny, so you can
leave this blank if you want.
However, we are going to select a specific person from the GEDCOM file. Again, rather than typing in
the name of the person, it is far preferable to select the person from the GEDCOM using the button
with the three small dots to the right of the Root Individual field. This will invoke the GEDCOM
Browser, a powerful browsing tool in it's own right.
After selecting a GEDCOM file, press the GEDCOM browse button (to the right of the Root
Individual) to select a person from the GEDCOM file. Once pressed, AA will have to read in your
GEDCOM file. This may take a few seconds if it's a large GEDCOM. You will then see the AA
GEDCOM Browser:

Note that the window is divided into a left panel, for typing names, dates, and other search criteria, and
a right panel, for viewing the selected person.
To search for the person we want, type the first and last name into the search fields at the top of the left
panel. Leave the dates blank. Then press the Find button. The browser will then look like this:

After pressing the Find button, the left panel is filled with a list of people named Seth Wheelock. There
are quite a few of them. We can find Seth more quickly if we know his birth date. To sort all
individuals by birth, click the Birth column header, underlined in red above. Now scan forward to find
the Seth Wheelock born on the expected date. In this case, it's the second person in the list. Double
click on the second Seth to display him in the right panel. By double clicking on the second Seth, he
becomes the selected individual, appearing at the top of the browse dialog, and in the right panel. The
browser dialog will then look like below:

At this point, we can press OK in the lower right to make Seth the root of our descendant report.
There is a lot more to know about the browser dialog. If you are interested, press the Help button.
After pressing the OK button in the browser dialog, the information about Seth will fill the Root
Individual fields, as shown below:

Next we want to choose specific options for the descendant report. To do so, push the Options button
highlighted in red above.
There are a variety of options to choose from. We won't discuss all of them here (read the Help).
Instead, to illustrate how it is done, we'll choose one option - enabling generation headings. This
option will place a heading in the document everytime a new generation is encountered, such as:
Generation Number 1
...
Generation Number 2
...
etc
Press the Options button, and select the Output tab (highlighted in red below).

Check the Include Generation Headings checkbox highlighted in yellow above. We'll leave the other
settings the same. Click OK, then click OK again to dismiss the Descendant Report Dialog. At this
point the main AA window will look like this:

Modifying Document Items
The layout panel on the left shows a title page, following by a table of contents, followed by a heading,
and the descendant report for Seth Wheelock.
To modify any of these document items, double click on the one you want to change. This will invoke
the same dialog that was originally shown for each of these document items. For example, double
clicking on the heading document item, highlighted in blue above, would display the dialog shown
below, giving you a chance to modify the heading:

Also, you can rearrange the document items by dragging them into a new position. And you can delete
a document item by selecting it, and pressing the keyboard delete button. Alternatively, you can select
it, press the right mouse button, and select either Delete or Modify from the popup menu:

Adding Source Citations
There are two ways to display source citations. The first is as a separate chapter at the end of the
document that lists all the sources referenced in the text. The second is a list of footnotes at the bottom
of each page that lists all source citations on the page.
The board of certified genealogists recommends footnote style sources. They are easier to read because
you only have to scan to the bottom of the page to see the source, rather than flipping pages to the end
of the document. So we'll choose footnotes over endnotes.
To select footnote style sources, press the Options button on the bottom of the AA window, underlined
in red above, then select the Citations tab:

Check the box labeled Include Source Citations, then choose select the Footnotes citation style
underneath (as shown above). Finally, press OK to accept your choices, and to dismiss the global
options dialog.

Creating a Name Index
Like descendant reports, a name index is created in two steps. First, add a Level 1 heading to provide a
heading, and to force the name index to start on a new page. Then add the index, which will display the
dialog shown below:

You have a choice between a one or two column index. The latter is more space efficient, so we'll
choose that. Also, you have a choice to enable links from the page numbers in the index back to the
page on which that person appears. Unfortunately, the Open Document Text format does not seem to
allow links in the index, so this option pertains to PDF output only. Links will show up in blue - so in
rare circumstances you might not want the blue in the PDF document. You can disable the links by
unchecking the Enable Index Links (PDF Only).
Like tables of contents, the name index must be expanded before you will see it in LibreOffice or
OpenOffice. To do this, select Tools->Update->Update All menu item. If you make any changes to
your document, you should rerun this menu item, otherwise the page numbers in the table of contents
and/or index might be incorrect.
Press OK to accept these changes and dismiss the dialog.

Creating the Document
We are now ready to create the document. The AA window should look something like this:

For good measure, select the Script->Save menu item to save the script in the previously designated
file, in this case - Tutorial.xml.
To create the document, press the Create ODT button highlighted in yellow above. This will create a
document viewable and editable with LibreOffice or OpenOffice. To work correctly, you must have
LibreOffice or OpenOffice installed on your computer.
If the document is more than a thousand pages or so, it can take a sizable fraction of a minute to create.
Once created, AA will ask if you want to view it:

Press Yes to view the document. If the document is large, it may take a little while to load into
LibreOffice or OpenOffice. This one is only about 15 pages long - it takes approximately 3 seconds to
load into LibreOffice.
As you scroll through the document, you'll notice that the table of contents and the name index appear
to be empty. Below the table of contents is a bright red reminder to update it:
To make the table of contents (TOC) and name index visible, select LibreOffice or OpenOffice
menu item 'Tools/Update/Update All' then delete this paragraph. If you prefer not to see this
hint, select Ancestral Author Plus menu item "Script/Preferences/Disable 'Table Of Contents'
Hint".
At first, it’s easy to overlook this step.

Spell Checking
One of the great advantages of ODT format is that the document can be spell checked in LibreOffice or
OpenOffice. By default, misspelled words are highlighted in red. By selecting a chunk of text, then
selecting the menu item:
Tools->Spelling
it is quite easy to correct words that have been misspelled. Of course, it is a good idea to correct these
misspellings in your GEDCOM too, otherwise you'll have to do these corrections every time you create
a new document.

Creating a PDF In LibreOffice
After spelling corrections, and whatever other changes are desired, you can create a PDF by selecting
LibreOffice menu item:
File->Export As->Export Directly As PDF
This will prompt for a PDF file name, and create the PDF. If you want more control over the options,
such as password protecting the PDF, or preventing readers from printing it, choose the following
LibreOffice menu item:
File->Export As->Export As PDF
This will bring up a dialog that gives many more options for creating the PDF.

An example of a PDF created this way is shown here. A few edits were done before creating this PDF:
•

some spelling corrections were made,

•

the spacing on the title page was adjusted,

•

a few quotations were indented, and

•

successive identical footnotes were replaced with Ibid.

Note that it is necessary to rerun the Update menu item after making these edits. This will ensure that
the table of contents and index refer to the correct page numbers.

Creating a PDF Directly From Ancestral Author Plus
There are a few advantages to creating a PDF directly from Ancestral Author Plus, without going
through LibreOffice or OpenOffice:
•

it is much simpler, just press the Create PDF button,

•

you don't need to install LibreOffice or OpenOffice, and

•

PDF name indexes can be linked back to the page on which that person appears, making it
much easier to find the page.

Of course, the negative is that you can't easily edit the PDF file, and there is no automatic spell
checking.
Here is an example of the PDF file that is created by pushing the Create PDF button.

Summary
This concludes the introductory tutorial. We have gone over the basic concepts, shown how to use AA
help, and created a simple genealogical descendant report. Other topics, such as:
•

importing images and creating image galleries,

•

importing formatted text,

•

selecting fonts, margins, and page numbering schemes,

•

changing the phrases used in the output text, and

•

changing the ordering of information in the report

will be covered in separate application notes.

